Actualizaciones periódicas de seguridad en Drupal 8

malmsteen

Beta
Verificación en dos pasos desactivada
Verificado por Whatsapp
¡Usuario con pocos negocios!
Desde
16 Abr 2019
Mensajes
39
Saludos amigos, trabajo con algunos temas de drupal para clientes y la actualización de seguridad de núcleo son las que dan más problemas me gustaría saber sus experiencias que que pasos usan para este tipo de actualizaciones:

Yo uso 2 métodos por ahora:

El primero es crear todo a.mano, el virtual host, importar la base de datos de mysql, configurar el sexting.php y correr el componer install lo que más suele darme problema es que siempre las dependencias faltan o tienen conflictos

El segundo método es usando Lando es súper útil no solo para drupal, en fin luego de configurar mi mando e importar la base de datos igual tengo problemas de dependencias y se me complica el asunto

Finalmente espero puedan compartir sus experiencias.
 

Jorjulus

Beta
Verificación en dos pasos activada
Verificado por Whatsapp
¡Usuario con pocos negocios!
Desde
18 Jun 2014
Mensajes
72
Saludos amigos, trabajo con algunos temas de drupal para clientes y la actualización de seguridad de núcleo son las que dan más problemas me gustaría saber sus experiencias que que pasos usan para este tipo de actualizaciones:

Yo uso 2 métodos por ahora:

El primero es crear todo a.mano, el virtual host, importar la base de datos de mysql, configurar el sexting.php y correr el componer install lo que más suele darme problema es que siempre las dependencias faltan o tienen conflictos

El segundo método es usando Lando es súper útil no solo para drupal, en fin luego de configurar mi mando e importar la base de datos igual tengo problemas de dependencias y se me complica el asunto

Finalmente espero puedan compartir sus experiencias.

Personalmente siempre utilizo drush para actualizar el core. Los módulos en Drupal 8 se instalan con composer.

Actualizar el core con drush: https://www.drupal.org/docs/updating-drupal/update-core-via-drush
Actualizar módulos con composer: https://www.drupal.org/docs/updating-drupal/update-modules-and-themes-using-composer

Un saludo
 

malmsteen

Beta
Verificación en dos pasos desactivada
Verificado por Whatsapp
¡Usuario con pocos negocios!
Desde
16 Abr 2019
Mensajes
39
Personalmente siempre utilizo drush para actualizar el core. Los módulos en Drupal 8 se instalan con composer.

Actualizar el core con drush: https://www.drupal.org/docs/updating-drupal/update-core-via-drush
Actualizar módulos con composer: https://www.drupal.org/docs/updating-drupal/update-modules-and-themes-using-composer

Un saludo
Si mi estimadio amigo pero a partir de drush 8.x ya no se puede usar comandos para ciertas versiones de drupal, por ejemplo drush 8 no da soporte para drupal +8.6, por lo cual hay que actualizar el drush a drush 9 y alli vienen los problemas ya que ahora se actualiza todo con composer editando elcomposer.json te dejo aqui una guia de las versiones y la compatibilidad https://docs.drush.org/en/master/install/
 

Jorjulus

Beta
Verificación en dos pasos activada
Verificado por Whatsapp
¡Usuario con pocos negocios!
Desde
18 Jun 2014
Mensajes
72
Si mi estimadio amigo pero a partir de drush 8.x ya no se puede usar comandos para ciertas versiones de drupal, por ejemplo drush 8 no da soporte para drupal +8.6, por lo cual hay que actualizar el drush a drush 9 y alli vienen los problemas ya que ahora se actualiza todo con composer editando elcomposer.json te dejo aqui una guia de las versiones y la compatibilidad https://docs.drush.org/en/master/install/

Que comandos te dan problemas?
 

malmsteen

Beta
Verificación en dos pasos desactivada
Verificado por Whatsapp
¡Usuario con pocos negocios!
Desde
16 Abr 2019
Mensajes
39
Te doy e
Que comandos te dan problemas?

Te doy un ejemplo en drush 9 ya no se puede usar drush up ni drush up drupal o drush up wisywyg por ejemplo ya no se puede actualizar asi
 

Crea una cuenta o accede para comentar

Debes ser un miembro para poder comentar

Crear cuenta

Crea una cuenta en nuestra comunidad

Acceder

¿Ya tienes una cuenta? Accede aquí


Arriba