error al instalar el vbulletin

  • Autor Autor bugadaltog
  • Fecha de inicio Fecha de inicio
B

bugadaltog

Beta
¡Usuario con pocos negocios! ¡Utiliza siempre saldo de Forobeta!
nose si hay que ponerlo aki pero keria instalar el vbulletin y me da este error mi hostis es yahoo businees
mysql_connect(): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (46) /foro/includes/class_core.php on line 311

alguien sabria de ke se trata
 
Si es en los primeros pasos has introducido mal los datos MySQL en el config.php.

Salu2.
 
Ese mensaje de error te dice que el hosting no se ha podido conectar al servidor MySQL. Por favor sigue el consejo de Vercceti, haznos saber si te pasa al mero inicio de la instalación, o, por favor especifica en qué paso recibes ese error exactamente.
 
a mi me da exactamente el mismo error... es la primera vez que configuro la base de datos, mi host es el server.com... no se mucho de esto... estoy tratando de configurarlo, habra alguna guia de que poner en cada lugar?
 
Acá está una guía de como instalar vBulletin:
Enlace eliminado

Espero te sirva. Es del 2008, pero aún es válida.

Saludos.
 
Step 2) Connect to the database
Attempting to attach to database
Error description: mysql_connect(): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (46) /foro/includes/class_core.php on line 311
[SIZE=+1]The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file. [/SIZE]Concretamente esto e slo ke me pasa
 
Eso quiere decir que en el "config.php" has puesto mal el usuario o la contraseña del mysql o que no le has dado permisos al usuario que has asociado a la base de datos, revisa eso 😉
 
Debes ingresar el nombre de tu base de datos, el usuario asignado a esa base de datos y su contraseña al archivo config.php. Ahí vas a ver las variables donde debes poner esa configuración, son las primeras variables.

te las dejo acá las que debes modificar:

PHP:
$config['Database']['dbname'] = 'forum';  //acá debes poner el nombre de tu base de datos, ya debes haberla creado en tu hosting.

$config['MasterServer']['username'] = 'usuario'; //acá debes poner el usuario que hiciste o te hicieron para esa base de datos.
$config['MasterServer']['password'] = '';  // y acá debe ir la contraseña del usuario asignado a esa base de datos.

Con eso ya vas a poder instalarlo. Ten en cuenta que esa información debe existir no es inventada. Debes saber que nombre tiene tu base de datos, ya que debes haberla creado y debes haberle asignado un nuevo usuario a esa base de datos.

Si no te funciona, por favor dinos que clase de panel tiene tu host, cpanel? o algún otro.
 
El mensaje apunta a que Ó esta mal configurado el /inludes/config.php Ó no lo has configurado.. Sigue lo que dice Elmer
 
todo esop ya lo hize tiene el phpmyadmin he puesto todo esop y el usuario que registre tiene todos los privilegios Gracias por las contestaciones
 
todo esop ya lo hize tiene el phpmyadmin he puesto todo esop y el usuario que registre tiene todos los privilegios Gracias por las contestaciones

Mira, Creaste la BD desde Cpanel??

Asignaste un nombre de usuario y contraseña a dicha base de datos??

Si es asi, tes los datos a mano

Revisa estas lineas de code en tu config.php


PHP:
 //    ****** DATABASE NAME ******
     //    This is the name of the database where your vBulletin will be located.
     //    This must be created by your webhost.
 $config['Database']['dbname'] = 'Aqui el NOMBRE de tu base de datos';

PHP:
//    ****** MASTER DATABASE USERNAME & PASSWORD ******
     //    This is the username and password you use to access MySQL.
     //    These must be obtained through your webhost.
 $config['MasterServer']['username'] = 'Aqui el NOMBRE DE USUARIO que le hallas asigando a la BD';
 $config['MasterServer']['password'] = 'Y aqui la Pass de el mismo nombre de usuario';
 
Gracias todos pero esop ya lo hize yo tengo el phpmyadmin y puede los datos esos son los correctos?
 
Por cierto otra duda compre la licencia de vbulletin 4.0 Suite pk cuando le doy a decargar me decarga una version inferior
 
elcoxx gracias pero eso es lo ke hize como dije puede la id y la contraseña del phpmyadmin ya que cuando creo una base de datos me la hace automaticamente y no tengo ke poner un nombre de usuario ni contraseñas GRACIAS A TODOS
 
Hola bugadaltog. Primero, bienvenido(a) seas a vBhispano.

Ahora, con respecto a tu problema, es preciso que nos digas si estás en un servidor gratuito, o uno pago. De eso depende los pasos que deberás seguir para rellenar los datos de tu 'config.php' correctamente.

Con respecto al problema de la descarga de vBulletin, desde el Members Area, cuando das click al enlace 'Download vBulletin 4 Publishing Suite', te llevará a la página de descarga. NO debes marcar la opción Donwload the latest version, sino la opción de abajo, y del menú desplegable seleccionar vBulletin 4 Release Candidate 4 (Unstable).

Mira la captura:

Ver el archivo adjunto 2405

Posterior a eso, baja y marca la casilla de verificación donde aceptas los términos y das click al botón 'Download'
 
Lo segundo ya esta selecionado estoy en un host de pago yahoo business y tengo el phpmyadmin para hacer bases de datos solo tengo ke introducir la clave y la id cuando accedo al phpmyadmin luego me deja crear las bases de datos sin contraseña solo poniendo el nombre de la base de datos
 
Lo de la contraseña es siempre la misma que usas para conectarte por ftp, intenta usando la misma.

Otro error que te puede estar pasando y te lo digo porque me paso, es donde dice localhost aveces para conectarse al server necesita otro enlace por ejemplo en el config.php te sale asi.

// ****** MASTER DATABASE SERVER NAME AND PORT ******
// This is the hostname or IP address and port of the database server.
// If you are unsure of what to put here, leave the default values.
$config['MasterServer']['servername'] = 'localhost';
$config['MasterServer']['port'] = 3306;

y si mi server no ocupaba localhost para conectarse a la base de datos, si no que en vez de usar localhost como estaba lo cambien por esto:

// ****** MASTER DATABASE SERVER NAME AND PORT ******
// This is the hostname or IP address and port of the database server.
// If you are unsure of what to put here, leave the default values.
$config['MasterServer']['servername'] = 'mysql-starka.com';
$config['MasterServer']['port'] = 3306;


Busca algun enlace en el Cpanel parecido a este mysql-starka.com y lo colocas en el config.php en vez de localhost, crea una base de datos nueva y vuelve a intentarlo.

Suerte.
 
Gracias por el mensaje es localhost lo he averiguado Gracias a todos por las contestaciones estoy desesperado
 
Hmm, lo que dice Hades es cierto..

No se man, seguro pones algo mal en el config.php y crees qno...
 
Atrás
Arriba