Error en la base de datos

  • Autor Autor djmlbp
  • Fecha de inicio Fecha de inicio
D

djmlbp

Gamma
¡Usuario con pocos negocios! ¡Utiliza siempre saldo de Forobeta!
Buenas, pues ahora mismo me acabo de comprar una licencia vB (antes usaba un nulled) y cuando quiero actualizar me aparece este mensaje:

PHP:
Database error in vBulletin :

mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Access denied for user 'youwarez_***'@'localhost' (using password: YES)
/home/***/public_html/includes/class_core.php on line 311

MySQL Error   : 
Error Number  : 
Request Date  : Saturday, October 31st 2009 @ 05:05:08 PM
Error Date    : Saturday, October 31st 2009 @ 05:05:08 PM
Script        : http://www.***.eu/install/upgrade.php
Referrer      : 
IP Address    : 174.34.141.37
Username      : 
Classname     : vB_Database
MySQL Version :

Yo he seguido todos los pasos de instalación como aparecen en una guía de este foro 🙁

gracias ante todo 😉
 
Pureba ejecutando la instalación de cero (usando el script foro.com/install/install.php). Al momento de que te envíe el mensaje de que una instalación de vBulletin ya existe, selecciona la opción de Actualizar. Si recibes el mismo mensaje de error, resube el archivo 'class_core.php' y verifica que los datos en el config.php sean correctos.
 
tenes mal el acceso configurado a la DB, verifica los datos en el archivo que esta en includes (config.php)

MASTER DATABASE USERNAME & PASSWORD

busca eso y verifica los datos.
 
En teoría creo que están bien, ¿pero como puedo saber la contraseña del usuario? 😀
 
La contraseña la asignaste cuando creaste en tu servidor un usuario que tenga acceso a esa base de datos.

Si no tienes usuario ni contraseña, debes crearlos en el apartado MySQL Databases o Bases de Datos MySQL en el cPanel de tu cuenta de hosting.
 
Si tenes Cpanel crea un usuario y lo agregas a la base de datos... o mas facil pon el nombre de uaurio de cpanel y la contraseña, con en nombre de la base de datos...

saludos
 
Muchas gracias jjuaannk, he creado un nuevo usuario y ya marcha todo perfecto 😉


Un saludo y gracias a los otros por ayudarme también 😀

Edito: mientras que estaba actualizando me ha salido este error:

PHP:
Database error in vBulletin 3.8.4:

Invalid SQL:
ALTER TABLE groupmessage
            CHANGE groupid groupid INT UNSIGNED NOT NULL DEFAULT '0',
            CHANGE postuserid postuserid INT UNSIGNED NOT NULL DEFAULT '0',
            CHANGE postusername postusername VARCHAR(100) NOT NULL DEFAULT '',
            CHANGE dateline dateline INT UNSIGNED NOT NULL DEFAULT '0',
            CHANGE ipaddress ipaddress INT UNSIGNED NOT NULL DEFAULT '0';

MySQL Error   : Unknown column 'groupid' in 'groupmessage'
Error Number  : 1054
Request Date  : Saturday, October 31st 2009 @ 06:23:35 PM
Error Date    : Saturday, October 31st 2009 @ 06:23:36 PM
Script        : http://www.youwarez.eu/install/upgrade_370b3.php?step=2
Referrer      : http://www.youwarez.eu/install/upgrade_370b3.php?step=2
IP Address    : 174.133.108.170
Username      : 
Classname     : vB_Database
MySQL Version : 5.0.81-community

¿Alguien sabe de que puede ser?
 
Dice que en la tabla 'groupmessage'
no esta groupid' in 'groupmessage'

te recomiendo hacer una instalacion limpia.. desde install.php

o si asi lo quieres entra por phpmyadmin y agrega esas 2 tablas en groupmessage

 
Dice que en la tabla 'groupmessage'
no esta groupid' in 'groupmessage'

te recomiendo hacer una instalacion limpia.. desde install.php

¿Si la hago perdería todos los posts, usuarios, temas, etc.. que tenía antes?
 
cuando venga la parte que te muestra las tablas y te pide que selecciones la que deseas borrar, no marques ninguna... y no pierdes nada
 
Si haces una instalación limpia, tienes que borrar la base de datos y crear una nueva. Hasta donde mis conocimientos alcanzan, no hay manera de instalar vBulletin desde cero con una base de datos ya usada. Por tanto, sí, pierdes usuarios, temas y todo.

Antes de probar una instalación limpia, hazle un mantenimiento a la base de datos.
 
Si haces una instalación limpia, tienes que borrar la base de datos y crear una nueva. Hasta donde mis conocimientos alcanzan, no hay manera de instalar vBulletin desde cero con una base de datos ya usada. Por tanto, sí, pierdes usuarios, temas y todo.

Antes de probar una instalación limpia, hazle un mantenimiento a la base de datos.
¿Podrías explicar eso detenidamente? ya que jjuuaannk está diciendo lo contrario.
 
Si haces eso que acabas de mencionar, borrarás toda la información, usuarios, temas, foros, mensajes de visita...
 
Puedes respaldar la base de datos parcial o totalmente.
Instala desde cero, (esto es ELIMINANDO TODAS LAS TABLAS EXISTENTES).

Una vez instalado el vbulletin , sube tu DB con bigdump.php por ejemplo.

Un slaudo
 
Si haces eso que acabas de mencionar, borrarás toda la información, usuarios, temas, foros, mensajes de visita...
Jooder, vamos a ver Chuta, si hago eso el foro se queda en 0, entonces dime pasito a pasito lo que tengo que hacer 😀

He revisado aquel post y he entendido esto:

1º Instalo vbulletin desde 0 sin base de datos de antes, es decir, como si fuera nuevo el foro
2º cuando estea todo listo importo las tablas que no pertenecían a ningun hack al foro.

¿Y ya está?

Disculpeme todos por "menearos" tanto la cabeza pero es que quiero hacer las cosas bien 😉
 
Podrías hacer eso que mencionas. O seguir el consejo de SEW810, usar el script bigdump.
 
He seguido lo que me ha dicho SEW810 pero cuando quiero importar la base de datos me sale lo siguiente:

Stopped at the line 362.
At this place the current query includes more than 300 dump lines. That can happen if your dump file was created by some tool which doesn't place a semicolon followed by a linebreak at the end of each query, or if your dump contains extended inserts. Please read the BigDump FAQs for more infos.


¿Que puedo hacer? 🙁

Edito: ya he resuelto el problema, gracias 😀
 
Atrás
Arriba