¿Cuándo va a morir PHP 5.6?

Torrecilla

Ni
Programador
Verificación en dos pasos desactivada
Desde
2 Feb 2013
Mensajes
3.587
Crédito(s)
4
Puntos
203
Hola a todos, alguien sabe cuándo va a morir PHP 5.6?, hace poco un cliente me contactó porque su hosting ya lo pasó a PHP 7.0

Yo sé que PHP 5.6 oficialmente ya no tiene soporte, pero como todos sabemos aún es super usado..., aún así no creo que le queden muchos años de vida hasta que sea reemplazado por 7.x

¿Qué opinan?
 

SnAFKe

VIP
Dseda
Verificación en dos pasos desactivada
Desde
6 Ago 2014
Mensajes
1.242
Edad
36
Crédito(s)
0
Puntos
915
Ya "murió"? sin el 7.1 se vence al final de año? andas un poco atrasadito.
 

Tony

VIP
Xi
Verificación en dos pasos activada
Verificado por Whatsapp
Desde
16 Jun 2011
Mensajes
4.470
Crédito(s)
1
Puntos
992
Servidor que tenga 5.6 es porque está abandonado.

Según yo ya hasta los shared upgradearon a 7.0 hace un rato.

Lo ‘fresco’ es 7.3, lo standard es 7.2 y el mes pasado salió la primera beta del 7.4 si no me equivoco.
 

Torrecilla

Ni
Programador
Verificación en dos pasos desactivada
Desde
2 Feb 2013
Mensajes
3.587
Crédito(s)
4
Puntos
203
Muchas gracias a todos por sus comentarios, ciertamente ya "murió", pero aún así los hostings tienen un soporte para PHP 5.6 como dice el compañero de arriba por la compatibilidad de scripts
 

JoseDieguez

Kappa
Verificación en dos pasos desactivada
Verificado por Whatsapp
Desde
31 May 2014
Mensajes
2.599
Crédito(s)
6
Puntos
2.949
Muchas gracias a todos por sus comentarios, ciertamente ya "murió", pero aún así los hostings tienen un soporte para PHP 5.6 como dice el compañero de arriba por la compatibilidad de scripts
Mientras sea el PHP Selector de CloudLinux (y no el MultiPHP de Cpanel), se puede seguir usando versiones PHP Antiguas con cierta "seguridad" pero perdiendo todas las ventajas y ganancias de velocidad de las nuevas versiones.

 

Rafark

Épsilon
Redactor
Verificación en dos pasos activada
Desde
27 Feb 2012
Mensajes
955
Crédito(s)
1
Puntos
111
Servidor que tenga 5.6 es porque está abandonado.
No tanto, es bien dificil forzar a los proveedores y clientes que actualicen, por muchos motivos. Las versiones de PHP por debajo de 7.0 corriendo wordpress son el 45% +- :

 

jmdoren

Beta
Verificación en dos pasos desactivada
Verificado por Whatsapp
Desde
31 May 2016
Mensajes
133
Crédito(s)
0
Puntos
0
A mi me pasó que al usar 7 agunos scripts no funcionaban, como soy programador los arreglé, pero quienes los bajaron hace años y aún le funcionan no creo que quieran cambiar porque sí. Algunos bancos aún usan Cobol....
 

PercyAid

VIP
Eta
Social Media
Verificación en dos pasos activada
Verificado por Whatsapp
Desde
16 Nov 2018
Mensajes
1.317
Crédito(s)
0
Puntos
1.390
Esta ya casi dejado de usar pero aún tiene soporte, pero si ya ves que quieres estar actualizado puedes subir al 7.0 o 7.1.
 

marjuanm

Épsilon
Programador
Verificación en dos pasos desactivada
Desde
16 Ago 2012
Mensajes
835
Crédito(s)
3
Puntos
44
muchas personas lo usan y bastante, hay scrip que solo manejan 5.6 y me he encontrado con 5.4 que me hace sentir que estoy en la prehistoria
Pues es que si algo funciona, no lo toques. Es por eso que hay muchos scripts "obsoletos", pero que funcionan y muchas veces los programadores prefieren no meterse en broncas con actualizar algo "por si acaso".
 

Torrecilla

Ni
Programador
Verificación en dos pasos desactivada
Desde
2 Feb 2013
Mensajes
3.587
Crédito(s)
4
Puntos
203
Pues es que si algo funciona, no lo toques. Es por eso que hay muchos scripts "obsoletos", pero que funcionan y muchas veces los programadores prefieren no meterse en broncas con actualizar algo "por si acaso".
Así es, yo me veo en esa situación ahorita..., en mis paneles principales uso una función de encriptado para el login, y el problema es que la función que uso sí sirve en la 5.6, pero en PHP 7.x está deprecated U_u, pero sí tengo que cambiarlo porque eventualmente algún día PHP 7.0 va a reinar este mundo y dejaremos de lado PHP 5.x
 

marjuanm

Épsilon
Programador
Verificación en dos pasos desactivada
Desde
16 Ago 2012
Mensajes
835
Crédito(s)
3
Puntos
44
Larga vida a PHP 5.3!
Si, yo también me resisto a abandonar mis desarrollos que funcionan sin problemas, el detalle es que en algunos servidores actualizados ya dan errores, ¿solución?, disminuir la versión php del servidor, no es lo mejor pero por el momento no hay más. Tendré que ir actualizando todo poco a poco.
 

arnego2

Kappa
Verificación en dos pasos desactivada
Verificado por Whatsapp
Desde
1 Mar 2015
Mensajes
2.607
Crédito(s)
0
Puntos
251
Supuestamente el php7 es mas rápido, aunque esto dicen en cada upgrade.
 

Torrecilla

Ni
Programador
Verificación en dos pasos desactivada
Desde
2 Feb 2013
Mensajes
3.587
Crédito(s)
4
Puntos
203
Si, yo también me resisto a abandonar mis desarrollos que funcionan sin problemas, el detalle es que en algunos servidores actualizados ya dan errores, ¿solución?, disminuir la versión php del servidor, no es lo mejor pero por el momento no hay más. Tendré que ir actualizando todo poco a poco.
Yo pienso lo mismo..., tengo proyectos personales que la verdad sí me toca cambiarlos a PHP 7.3 (2-3 funciones, pero igualmente es tiempo...) porque tarde o temprano va a desaprecer la 5.x y si desaparece "de jalón" me afectaría bastante...

Los proyectos de unos poquisimos proyectos los voy a dejar como están, ya cuando pase eso contrato a un programador y listo (no porque yo no sepa, si no por tiempo).
 

jmdoren

Beta
Verificación en dos pasos desactivada
Verificado por Whatsapp
Desde
31 May 2016
Mensajes
133
Crédito(s)
0
Puntos
0
Supuestamente el php7 es mas rápido, aunque esto dicen en cada upgrade.
La migración porque "es más rápido" no siempre es aconsejable, si te da un montón de dolores de cabeza e inviertes mucho tiempo y después la página que se generaba en 0.003 segundos lo hace en 0.0028 fue un mal negocio. En mi experiencia y porque uso mucho base de datos, es mejor concentrar los esfuerzos en optimizar la base de datos y sus consultas. Para la experiencia de usuario optimiza el tamaño de los archivos, pero con procesadores cada vez más rápidos las diferencias entre una versión de php y otra son insignificantes para el humano.
 

Arriba